Talk:PPU registers

From Nesdev wiki
Revision as of 17:34, 1 March 2010 by Banshaku (Talk | contribs)

Jump to: navigation, search

Naming the registers

Am I the only one being annoyed by those "PPUMASK" "PPUSCROLL" etc... names ? Because Mr Tepples often refers them as it doesn't mean everyone often refers them as it. I like to use plain $2000, $2005, etc... Personally I'd vote for removing references to those names from the Wiki but I don't want to force it if other people disagree. Bregalad 21:29, 24 February 2010 (UTC)

It depends. It's not only Tepples that promoted those names. I'm a firm believer that using symbolic constants makes the code easier to read. As long both are available in the wiki I don't see the issue.

I can give you an example as code. Which one is clearer when you read back the code?


lda #%1010000
sta $2000


In another file (nes.h)

PPU_CTRL_NMI %10000000
PPU_CTRL_SPRITE8x16 %00100000
PPU_CTRL $2000


Somewhere in the code


Once you know the convention, it makes the code easier to read. Of course for the registers only it could be argued for a while since there is not that much on the nes but it's always good to follow good programming practice. In a professional environment, I will always promote the second once since it makes the code clearer.

You don't know how many time I saw code samples for newb with no comments at all and you have to figure out what the hell was done with anonymous labels to make it worst. At the least those constants give some visual feedback on what you're trying to do. It's only a matter of getting used to the naming convention.

In brief, I think it's a good practice to use them but nobody is forcing you do to so. There's just there to try to make a convention and of course not everyone will agree with it (i.e. see how many linux distro..)

Banshaku 01:35, 25 February 2010 (UTC)

Well it's fun because I always do it like your "bad example" exept I write numbers in hex instead of binary, and I never had problems reading it. Symbolic names just makes the thing longer and more confusing. In fact I think it is the exact opposite of what you said - it makes things harder to read in my opinion. Then it depends if you remember best words or numbers - I know I remember numbers better personally.

Like you said, as long as there is both there isn't any problem... but my issue is that I found several pages on the Wiki which ONLY refers the symbolic names which are nothing official anyways. So my proposal would be to not touch this page, but change the others to mirror the numbers (e.g. $2001) instead of symbolic names that makes few sense (PPUMASK really makes no sense to me it sounds like carnival or something).

Again I don't want to force anything but I'd vote for at least replacing all instances which ONLY have the symbolic names to show the true register instead. Bregalad 08:20, 25 February 2010 (UTC)

I was not aware that some page of the wiki only refer to the name. In that case, yes it can be confusing since there is no official standard for naming them. To make both crowd happy, we could always put both at the same time too.

Which pages are like that?

As for using constants For the registers, the benefit is quite negligible since there is not that much but for flags or your own values in your game, it will save you from many headache when you use the same value many time. Of course, if you use long name and you have to remember all of them by heart, everybody will agree with you and say it's quite a pain in the butt (I do agree) but with a good editor, the editor will give you suggestion once you start to type a word. For example, in Visual Studio, Eclipse and many IDE, if I would type PPU, it would give me a suggestion list of all the words that start with PPU. In the case of nes programming this is an issue because there is no such editor that gives that functionality. I wanted to make one for that reason since I cannot remember all my constants, which is normal.

Banshaku 12:05, 25 February 2010 (UTC)

See GBATEK for the kind of style that I was attempting to follow when I instituted the PPU registers' names in the first place. The GBA community never refers to registers by their address. --Tepples 12:55, 25 February 2010 (UTC)

Tepples there is a big difference : The NES adresses are 16-bit and so you only have 4 digits per adress, which makes them much easier to remember. Another big differences is that all those names are made up - they are nothing official and probably aren't "often refereed as" as this page says Ian Bell uses the following definitions in his open source "tank demo" so if anything were to be official it'd look more like this (and again I doubt it's official it's probably made up by Ian Bell himself) :

VCR:		EQU	$2000	; video control reg base address
VSTAT:		EQU	VCR+002	; video general status register
OAM_ADR:		EQU	VCR+003 ; sprite attribute address register
SCROLL:		EQU	VCR+005 ; scroll h/v registers appear here
VRAM_ADR:		EQU	VCR+006	; video address register
VRAM_DAT:		EQU	VCR+007	; video data register


CONTROLLER1:	EQU	$4016		; Joystick and DMA
CONTROLLER2:	EQU	$4017		; Ports

So according to what Banshaku said, I guess I can go ahead and remove places where registers are refereed only by their GBA-style name and replace them with true adreses. If this cause problems someone can still undo the changes. --Bregalad 15:10, 25 February 2010 (UTC)

Game Boy addresses are 16-bit, yet the same fellow behind GBATEK also wrote Pan Docs. --Tepples 16:02, 25 February 2010 (UTC)

We should just be careful thought. It's not because there is no official naming convention coming from Nintendo that we cannot make our own in the first place. If we go that extreme, we could say that we don't agree with Loopy_V/Loopy_T naming convention because that is not official too.

There is nothing wrong to try to make a naming convention that seems simple for new users. The one shown above is not any simpler the the currently proposed one on the wiki. It's all a mater of preference. Don't forget that people have complained many time that the wiki was "not organized" so we shouldn't shoot down people that try new ideas. There is nothing wrong we that. You may have missed that Ddribin did some example in it's own sandbox for some possible formatting and naming convention here. I thought his idea was interesting and it passed under the radar of everyone.

Banshaku 23:46, 25 February 2010 (UTC)

I just noticed this mass-removal of named registers and it's ridiculous. The point of this Wiki is to make thigs clearer. Using numeric addresses everywhere adds needless detail and harms its primary purposes of educating NES programmers.

The point of using an assembler is to work at a higher level than machine code. The assembler allows you to use the names of instructions rather than their op codes. Likewise, it allows one to give addresses names and work with them. Labels in programs are one example, and named constants are another. If one really believed that using hexadecimal values instead of named registers was good, one would have to argue the same for labels and instructions, and thus use only .byte directives in the assembler.

New NES programmers have plenty to remember already. Being able to say PPUSTATUS instead of $2002 lightens their mental load, and reminds them of the register's purpose wherever it's used, without having to look anything up. Even an experienced NES programmer who takes a break will have to re-learn the values to some extent, and make more errors during the process.

All NES programmers make typos when programming. Making a typo on PPUSTATUS will result in an assembler error in almost all cases, rather than a program that misbehaves. Making a typo on $2002 can easily result in a program that assembles fine but fails to work, without any way to easily find the typo.

When a programmer is reading source, addresses like $2002, $2003, $2005 all tend to look somewhat alike, while PPUSTATUS, SPRADDR, and PPUSCROLL are more distinct, and can be set up as keywords for the syntax highlighter.

If one is used to using numeric addresses, he will have to learn the names for them, but this has none of the disadvantages listed above. The names are based on the function, rather than arbitrary numbers. And misremembering a name will be caught almost immediately. I can't help but think that the desire for removal of names is to avoid having to learn them, or make up for deficient tools or something.

Blargg 22:18, 28 February 2010 (UTC)

It's a battle of the B's, and I'm still the odd one out even after buying a copy of Bee-52 :-)

Martin Korth uses purported official names in GBATEK and Pan Docs, but he appears not to use names in Everynes. My early GBA header files used different names from the names in GBATEK. Part of this was to be different on purpose to avoid appearing to support the use of unlawfully acquired trade secrets. What are "official" names other than names in leaked Nintendo manuals? The other part was to take advantage of the various arrays implicit in the GBA register map. In fact, some elements of my naming scheme, particularly with respect to these arrays, eventually made it into devkitPro's libgba header file, which otherwise follows GBATEK. (See for example BGCTRL[].)

So, Bregalad, do you object to the idea of having the community invent a consistent set of names, or do you just object to the specific names I invented? --Tepples 02:44, 1 March 2010 (UTC)

I tend to agree to what Blargg said. Making a typo on a name will make the compiler fail but a typo on an address won't. By using constant you avoid that possible issue.

For beginners, those constants are a must. How many times when we look at the code sample they send that we can be sure that they really meant $200X and it was not a typo? With the constant, it makes it plain obvious and easier to correct them.

I think it will be hard to make everyone happy in that case. For now, we only have one person objecting to this naming convention. I just checked the updated page and since I didn't program the nes for a while it didn't make any more sense to me anymore. When you have to juggle with many platforms during the day, constants and the proper tools the way to go. If I could find an editor that do some intellisense with my own defined constant I would be happy. I need to check if Notepad++ can do it, that would be great.

Banshaku 03:57, 1 March 2010 (UTC)

Well I don't know. You guys says a newbie already have a lot of things to learn, but learning those confusing names just sounds like one more thing to learn to me. Remembering "PPUSTATUS" you have to remember 9 letters instead of 4 numbers in $2002 which is more complicated (you really have to remember 1 number, because the first 3 are always $200x). I also disagree about the typo things, you can't really do a typo when typing "$2002" without noting it immediately, however you can very easily do typos with words.

You are right tough about that there is no reason the community can't made up names - and I wasn't intending we should replace those names by more "official" names, just using the register is fine for me. My references to Ian Bell's code (which isn't really "leaked" since he did give it himself on purpose to the community) was misplaced - I didn't intend to use them.

About the argument that it would be less confusing when switching to from a system to another, I disagree. Every system has other registers anyways so it wouldn't change a thing.

I just think most of those name didn't make sense to me and are too long to be remembered, but I don't really care if you all like them go away and use them (and undo my modifications), I'll just not use them in my code and anyone is free to use them. It's just that I figured those names caused me trouble as I always had to had the registers page open in another tab to convert from those names to actual registers.Bregalad 07:57, 1 March 2010 (UTC)

- It's not ridiculous. I don't play very often with NES assemblers, but I suppose that those labels should be pre-defined in an header file perhaps? Really, it's pointless. The $2002 means PPUSTATUS; fine. Is this more educational than $2002? Do you know about ppu address mirroring, of address AND 7, just for the case?

- Personally, I prefer the numbered registers instead of labeled ones. If it's not part of a compiler, it's up to the user to define a couple of labels. Yup, it avoids errors, but I _really_ dunno you would do such mistake; probably, your algorithm or opcode usage has more chances to spot an error than a $200X "whoops". Zepper, 1 March 2010

As for number of characters to remember: "PPU" is a concept, and "status" is a concept, and humans are better at remembering concepts. It's easier to remember a name like "Jennifer" than a phone number like "903-5768". Otherwise, why do we even use assemblers at all? "LDA #" has more characters than "A9".

Different people have historically used different names. What MOS Technology, its second sources, and ARM call "EOR" everyone else calls "XOR". Likewise, Sony's highly-6502-inspired SPC700 CPU uses different mnemonics even for instructions that by rights should be the same. "MOV A,X" could have been "TAX" for familiarity to people who have programmed the NES and the other half of the Super NES.

Bare addresses have different purposes based on what bus they're on. Is $2000 the first PPU control register, or is it the start of the first nametable?

Register address mirroring is probably more useful to emulator developers and people trying to obfuscate or digitally fingerprint code than to developers of original NES software.

Yes, the constants should be predefined in a header file, and the header file should be on this wiki. I fully intend to make such a header file at least for ca65 once we standardize the names and other parts of the style guide.

--Tepples 17:07, 1 March 2010 (UTC)

You are right that concepts are easier to remember than numbers. However you say that if I don't use the labels you made up to assign registers, I might as well not use an assembler, which is absolutely not what I meant. I am not against labels as a whole - I am just against the fact that some labels one guy made up were used on this wiki instead of the real addresses of the register without any reference to the real address next to it, and that the name of the labels themselves didn't make much sense to me.

I completely disagree that this should avoid errors. Since I started coding for the 6502 I've had to deal with MANY typo errors, but they were always for other reasons (misspelling of labels, bad use of anonymous labels and confusion betwen X and Y should hold the top tree (X and Y are one next to the others here, unlike english keyboards)). So if you really want to use the labels on the wiki go ahead, but then also refer to the register name, or at lest link to it, so that people who don't make any sense from these names can have an idea what you are talking about.Bregalad 17:48, 1 March 2010 (UTC)

The comment about not using an assembler at all was a bit of hyperbole. I have a disability that sometimes makes it difficult for me to discern the line between what is acceptable and what is not. As a coping mechanism, I sometimes use hyperbole to establish lower and upper bounds for the discussion. But if the solution is to link to the article defining the labels from every other article that uses the labels, I have no problem with that. Redirects would help with that; it'd be as easy as, say, [[PPUSTATUS]]. --Tepples 18:44, 1 March 2010 (UTC)

- Quick question: perhaps other people want to debug or trace your code using a disassembler. Does it display $2002 or PPUSTATUS? ;) So, it's something fully optional, including empirical labels for such registers. Well, regarding $2000, it was silly. We have CPU and PPU addressing the things! How would you differ the labels? --Zepper 21:25, 1 March 2010 (UTC)

Quick answer: The disassembler displays whatever label set you have loaded in. It starts with just the 30 registers of the NES, but as I learn more about how a game works, the label set fills up with memory locations and subroutine entry points. If I really wanted to thwart disassembler users, I could have the assembler generate 10 random bits and make them different for every access to the PPU registers. This brings up another idea: if we make a header file for ca65, we could also make a label file for FCEUX. --Tepples 21:41, 1 March 2010 (UTC)

Actually, I don't know any disassembler with such feature. Plus, there are lots of good h4ck3r5 that uses only an hexa editor. ^_^;; But perhaps it's another story. --Zepper 21:56, 1 March 2010 (UTC)

Here's an example of what I'm using in all my nes project: CA65 constants. Yes, the name are verbose because I'm trying to find a naming convention that make sense. I'm still in a trial and error process. I always had that file open when I need to use them but I found out that with Notepad++ you can create a list of word that can work like intelissense in Visual studio. This mean I won't need to remember them anymore once I create that file for my editor.

Banshaku 23:34, 1 March 2010 (UTC)